Code review comment for lp://staging/~gary/juju-gui/nodeChangeHandler

Revision history for this message
Gary Poster (gary) wrote :

*** Submitted:

Refactor and rename BindingEngine._storeChanged

This is a small clean-up branch in preparation to cleaning up some of
the conflict resolution edge cases. It is largely about refactoring and
renaming BindingEngine._storeChanged.

* BindingEngine._storeChanged is now called _nodeChangeHandler.
* That method simply calls out to the new method _nodeChanged. It takes
a node rather than an event with a node.
* Factored _getBinding out of _nodeChanged to make the code read better
and to test the functionality independently.
* Adjusted tests to use _nodeChanged.
* Refactored tests to reuse more code and clean up some lint.
* Added tests for _getBinding.

In addition to those related changes, I made one more peripheral change:
I removed an unused argument to unsyncedFields.

R=benjamin.saller
CC=
https://codereview.appspot.com/13265045

https://codereview.appspot.com/13265045/

« Back to merge proposal