A few comments:
Line 51: s/not cell_number in/cell_number not in/
Line 104: I factored out the "len(cells) - 1" into a local variable outside the loop for readability and (possibly) improved performance.
Lines 105-108 can be better written as: cell_size = self.cached_cell_size.get(cell_number, 0)
Line 110: Removed unnecessary parens.
I'll fix those and sponsor this into trunk (and upload) along with your LP: #1105363 fix.
« Back to merge proposal
A few comments:
Line 51: s/not cell_number in/cell_number not in/
Line 104: I factored out the "len(cells) - 1" into a local variable outside the loop for readability and (possibly) improved performance.
Lines 105-108 can be better written as: cell_size. get(cell_ number, 0)
cell_size = self.cached_
Line 110: Removed unnecessary parens.
I'll fix those and sponsor this into trunk (and upload) along with your LP: #1105363 fix.