Merge lp://staging/~tealeg/landscape-client/monitoring-plugins-scoped-resynch into lp://staging/~landscape/landscape-client/trunk
Proposed by
Geoff Teale
Status: | Superseded |
---|---|
Proposed branch: | lp://staging/~tealeg/landscape-client/monitoring-plugins-scoped-resynch |
Merge into: | lp://staging/~landscape/landscape-client/trunk |
Prerequisite: | lp://staging/~tealeg/landscape-client/broker_handles_scoped_resynch |
Diff against target: |
718 lines (+261/-64) 31 files modified
landscape/broker/client.py (+23/-2) landscape/broker/tests/test_client.py (+48/-0) landscape/monitor/aptpreferences.py (+1/-0) landscape/monitor/cephusage.py (+1/-0) landscape/monitor/computerinfo.py (+1/-0) landscape/monitor/computeruptime.py (+1/-0) landscape/monitor/cpuusage.py (+1/-0) landscape/monitor/loadaverage.py (+1/-0) landscape/monitor/memoryinfo.py (+1/-0) landscape/monitor/mountinfo.py (+1/-0) landscape/monitor/networkactivity.py (+1/-0) landscape/monitor/networkdevice.py (+1/-0) landscape/monitor/packagemonitor.py (+1/-2) landscape/monitor/plugin.py (+2/-2) landscape/monitor/processorinfo.py (+1/-0) landscape/monitor/rebootrequired.py (+1/-0) landscape/monitor/swiftdeviceinfo.py (+1/-0) landscape/monitor/temperature.py (+1/-0) landscape/monitor/tests/test_aptpreferences.py (+2/-1) landscape/monitor/tests/test_cephusage.py (+5/-4) landscape/monitor/tests/test_computerinfo.py (+2/-1) landscape/monitor/tests/test_mountinfo.py (+2/-1) landscape/monitor/tests/test_plugin.py (+43/-0) landscape/monitor/tests/test_processorinfo.py (+2/-1) landscape/monitor/tests/test_rebootrequired.py (+2/-1) landscape/monitor/tests/test_swiftdeviceinfo.py (+2/-1) landscape/monitor/tests/test_updatemanager.py (+2/-1) landscape/monitor/tests/test_usermonitor.py (+103/-44) landscape/monitor/updatemanager.py (+1/-0) landscape/monitor/usermonitor.py (+4/-3) landscape/reactor.py (+3/-0) |
To merge this branch: | bzr merge lp://staging/~tealeg/landscape-client/monitoring-plugins-scoped-resynch |
Related bugs: |
Reviewer | Review Type | Date Requested | Status |
---|---|---|---|
Alberto Donato | Approve | ||
Landscape | Pending | ||
Review via email: mp+173207@code.staging.launchpad.net |
This proposal supersedes a proposal from 2013-07-05.
This proposal has been superseded by a proposal from 2013-07-12.
Description of the change
This branch adds a scope attribute to the MonitorPlugin class and checks incoming resynchronize-
To post a comment you must log in.
Looks good to me! +1
#1:
+ scope = "openstack"
The scope name seems a bit too specific, as swift and ceph could be used outside of an OpenStack deployment.
Maybe something like "storage"?
2:
self. assertEqual( self.plugin. get_message( ),
- {"type": "wubble", "wubblestuff": 1})
+
+ {"type": "wubble", "wubblestuff": 1})
This seems like an accidental change.