Merge ~racb/git-ubuntu:more-project-rename into git-ubuntu:main

Proposed by Robie Basak
Status: Merged
Merged at revision: 4d497a77ae031f49980ae50af5b1fb079fce3e8f
Proposed branch: ~racb/git-ubuntu:more-project-rename
Merge into: git-ubuntu:main
Diff against target: 1035 lines (+39/-88)
18 files modified
dev/null (+0/-17)
doc/README.md (+10/-10)
doc/release-process.md (+6/-29)
gitubuntu/git_repository.py (+1/-1)
gitubuntu/importer_service_broker.py (+9/-0)
gitubuntu/repo_builder.py (+1/-1)
gitubuntu/scriptutils.py (+0/-18)
gitubuntu/source_builder.py (+1/-1)
man/man1/git-ubuntu-clone.1 (+1/-1)
man/man1/git-ubuntu-export-orig.1 (+1/-1)
man/man1/git-ubuntu-import.1 (+1/-1)
man/man1/git-ubuntu-merge.1 (+1/-1)
man/man1/git-ubuntu-queue.1 (+1/-1)
man/man1/git-ubuntu-remote.1 (+1/-1)
man/man1/git-ubuntu-submit.1 (+2/-2)
man/man1/git-ubuntu-tag.1 (+1/-1)
man/man1/git-ubuntu.1 (+1/-1)
setup.py (+1/-1)
Reviewer Review Type Date Requested Status
Server Team CI bot continuous-integration Approve
Christian Ehrhardt  Approve
Bryce Harrington Abstain
Canonical Server Reporter Pending
Review via email: mp+425379@code.staging.launchpad.net

Description of the change

This is a followup from https://code.launchpad.net/~racb/git-ubuntu/+git/usd-importer/+merge/424877 where Bryce found some incomplete parts of the project rename that were outside the scope of that MP:

commit 002e452c9dd413b9a22b7ff8d0d3c277a3ae0a3a
  - Verified list exists at https://lists.ubuntu.com/mailman/listinfo/ubuntu-distributed-devel
  - List adopted for git-ubuntu use on https://lists.ubuntu.com/archives/ubuntu-distributed-devel/2018-May/001222.html
  - LGTM

commit 2f0e8556c1a0c36ffefe80cfc3c0f5e3adb49b28
  - Is the name "USD Import Team" still valid as the name for the new list? If not, then the from line in the CHANGELOG_TEMPLATE needs updated.
  - `grep -sir usd-import-team .` shows additional references to the old team in setup.py and a few docs. The urls no longer resolve, so guessing this commit would be a good point to update all those too.
  - There are also other mentions of 'usd-import' in the codebase, such as some man page references to bugs.launchpad.net/usd-importer and git.launchpad.net/usd-importer, etc. which no longer resolve, and to some other email addresses that may no longer be valid. Maybe you want to cleanup those in a different commit in this branch, or in this commit?
  - Needs Fixing

commit 5aad1110b2b849e4704c37751cf656ae14e3b3bb
  - No other references to 'usd-importer-bot' in the codebase
  - There is still the 'usd-importer' service, but afaict that'll keep the name, and in any case is unrelated to the bot.
  - LGTM

To post a comment you must log in.
Revision history for this message
Michał Małoszewski (michal-maloszewski99) wrote :

Looks good, but waiting for approval from others.

Revision history for this message
Server Team CI bot (server-team-bot) wrote :

PASSED: Continuous integration, rev:7ef484a96b74df4ded94cff0096c88f5a1244a1a
https://jenkins.canonical.com/server-team/job/git-ubuntu-ci/7/
Executed test runs:
    SUCCESS: VM Setup
    SUCCESS: Build
    SUCCESS: VM Reset
    SUCCESS: Unit Tests
    IN_PROGRESS: Declarative: Post Actions

Click here to trigger a rebuild:
https://jenkins.canonical.com/server-team/job/git-ubuntu-ci/7//rebuild

review: Approve (continuous-integration)
Revision history for this message
Bryce Harrington (bryce) wrote :

You're doing too many disparate things in a single commit. Just focus this on project renaming.

I'd want to see better justification for deletion of the migration code, given that it represented a large investment of effort to implement in the first place, however I am biased against deleting my own contributions. So you may be better to find someone else to do the reviewing. As I understood it, you disabled it (temporarily I assumed) to facilitate migrating the code, so it is startling to see it on the chopping block.

review: Abstain
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

I guess the underlying case here is that we want "some kind of monitoring" to alert us of failed imports, but do not insist too hard which solution that is.

Is there already something new present and working that will replace the old mailing feature?
I know it was off recently, but dropping it entirely from the codebase without a successor feels odd indeed.

If there is a plan or even code already we could - while dropping the mail feature - at least outline a bit like "this used to use mails summarizing the fail reason which no more works because X<reason>, instead as part of version x.y <plan> it will switch to report such issues via Y<solution that fits better because>".

If we do not yet have an Y, maybe we should keep X for now (even disabled)?

Revision history for this message
Robie Basak (racb) wrote :

On Mon, Jun 27, 2022 at 07:06:43AM -0000, Christian Ehrhardt  wrote:
> I guess the underlying case here is that we want "some kind of monitoring" to alert us of failed imports, but do not insist too hard which solution that is.
>
> Is there already something new present and working that will replace the old mailing feature?

Since then we now have the tracking system. We have a database tracking
progress and can list errored imports from the database. So we aren't
getting directly notified, but can generate a report of everything that
needs retrying, for example.

In practice, this emailing code was useful when we had many failures for
various reasons and were struggling to keep track of them. Now, the
majority of those issues are fixed, the remaining failures are mostly
transient and I don't think that receiving emails for them invidiually
would be useful any more. Maybe we should have some automatic retry
system hit failures first, but we don't currently have that.

I spoke to Andreas about future design for observability/monitoring and
I think the conclusion was that InfluxDB probably made sense to log
"events" such as "package A succeeded; processing time X" and "package B
failed". But no, that's not there today, and it's not currently a
priority to implement.

> I know it was off recently, but dropping it entirely from the codebase without a successor feels odd indeed.

I'm surprised at this reaction because I don't see this as a decision
that's being made now. The code has already been "skeleton" for a long
time.

It is already effectively dropped - it isn't connected to any live code.
It's de-facto not being maintained _because_ it isn't connected to
anything so doesn't get adjusted as the rest of the code changes.
Reconnecting it would involve some work because the paradigm has
changed. We no longer have a set of failures that happen in sequence
that we then batch the results email out.

Removing it is merely cleaning up the source tree for a change that
already took place. If we want to bring it back to live status later, it
will still be in VCS. It makes little difference whether it is in the
source tree or in VCS history except that if it stays I have to keep
half-maintaining it when refactoring.

That's the cost. What would be the benefit?

Revision history for this message
Server Team CI bot (server-team-bot) wrote :

PASSED: Continuous integration, rev:1fa430fc8efd64bfda20bd8b5321ef790f6e162b
https://jenkins.canonical.com/server-team/job/git-ubuntu-ci/9/
Executed test runs:
    SUCCESS: VM Setup
    SUCCESS: Build
    SUCCESS: VM Reset
    SUCCESS: Unit Tests
    IN_PROGRESS: Declarative: Post Actions

Click here to trigger a rebuild:
https://jenkins.canonical.com/server-team/job/git-ubuntu-ci/9//rebuild

review: Approve (continuous-integration)
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Thanks Robie,
since the feature was no more used for a while and is no more as-needed due to the queuing I agree to merge this MP. Thanks for adding an acknowledgement to what we had in the past and a plan for what we should/could add (and where) - that is the least we can do when removing code that was quite useful when it was active still.

If along the PS5 setup we identify any kind of need to mail us about status please do not hesitate to revive fragments of this as-needed (would not in the same place anyway, but some elements might still be valid).

review: Approve
Revision history for this message
Server Team CI bot (server-team-bot) wrote :

PASSED: Continuous integration, rev:4d497a77ae031f49980ae50af5b1fb079fce3e8f
https://jenkins.canonical.com/server-team/job/git-ubuntu-ci/10/
Executed test runs:
    SUCCESS: VM Setup
    SUCCESS: Build
    SUCCESS: VM Reset
    SUCCESS: Unit Tests
    IN_PROGRESS: Declarative: Post Actions

Click here to trigger a rebuild:
https://jenkins.canonical.com/server-team/job/git-ubuntu-ci/10//rebuild

review: Approve (continuous-integration)

There was an error fetching revisions from git servers. Please try again in a few minutes. If the problem persists, contact Launchpad support.

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
The diff is not available at this time. You can reload the page or download it.

Subscribers

People subscribed via source and target branches