Merge lp://staging/~oif-team/libgrip/device-types into lp://staging/libgrip

Proposed by Chase Douglas
Status: Merged
Merged at revision: 44
Proposed branch: lp://staging/~oif-team/libgrip/device-types
Merge into: lp://staging/libgrip
Diff against target: 391 lines (+196/-3) (has conflicts)
4 files modified
configure.ac (+2/-2)
examples/rectangle-mover/gesture.c (+35/-0)
src/gripgesturemanager.c (+150/-1)
src/gripgesturemanager.h (+9/-0)
Text conflict in examples/rectangle-mover/gesture.c
Text conflict in src/gripgesturemanager.c
To merge this branch: bzr merge lp://staging/~oif-team/libgrip/device-types
Reviewer Review Type Date Requested Status
Stephen M. Webb (community) Approve
Review via email: mp+64460@code.staging.launchpad.net

Description of the change

Add an argument to libgrip subscriptions to subscribe only on specific device types:

Possible values:

* GRIP_DEVICE_ALL

  or the logical OR'ing of:

* GRIP_DEVICE_TOUCHSCREEN
* GRIP_DEVICE_TOUCHPAD
* GRIP_DEVICE_INDEPENDENT

To post a comment you must log in.
Revision history for this message
Stephen M. Webb (bregma) wrote :

(1) If you initialize GRIP_DEVICE_ALL to (GRIP_DEVICE_TOUCHSCREEN | GRIP_DEVICE_TOUCHPAD | GRIP_DEVICE_INDEPENDENT) it makes the logic in grip_devices_for_type() simpler and makes a lot of sense.

(2) The devices field of the GripGestureManagerPrivate structure should be initialized in grip_gesture_manager_init() not in grip_gesture_manager_constructor(), but grip_get_devices() still should be called from grip_gesture_manager_constructor().

(3) The public API change breaks the ABI, so this change should really include a version bump. This version is not backwards compatible with earlier versions.

review: Needs Fixing
44. By Chase Douglas

Rework GRIP_DEVICE_ALL so it is the union of all the device types

45. By Chase Douglas

Move devices array allocation to object init time from construction time

46. By Chase Douglas

Bump the version to 0.2.0

This brings with it API and ABI breakage

Revision history for this message
Chase Douglas (chasedouglas) wrote :

I believe I've addressed all three comments now. Please re-review.

Revision history for this message
Stephen M. Webb (bregma) wrote :

Nice work, guys. Sorry for the review delay.

review: Approve
47. By Chase Douglas

Remove GRIP_DEVICE_ALL from GripDeviceType enum

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
The diff is not available at this time. You can reload the page or download it.

Subscribers

People subscribed via source and target branches

to all changes: