lp://staging/~mc-return/compiz/compiz.merge-fix1172913-blacklist-composite-and-opengl

Created by MC Return and last modified
Get this branch:
bzr branch lp://staging/~mc-return/compiz/compiz.merge-fix1172913-blacklist-composite-and-opengl
Only MC Return can upload to this branch. If you are MC Return please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
MC Return
Project:
Compiz
Status:
Development

Recent revisions

3672. By MC Return

Bring the ccsm_disable_unity_checkbox.patch inline, because it will not
hurt upstream Compiz in any way
Also blacklist the plugins composite and opengl in Widgets.py, because
those are essential for Compiz to work
This removes the checkboxes to enable/disable "OpenGL" and "Composite"
from the main CCSM screen. They can still be disabled in their respective
CCSM subscreens.

TODO: Evaluate with Sam if we should also remove the checkboxes from
      other plugins essential for minimal Compiz usage, like decor, move,
      place and resize for example...

3671. By Sam Spilsbury

Explicitly check if the smart pointers are null rather than converting
implicitly to bool as boost 1.53 now marks the bool operator as explicit

(LP: #1172601). Fixes: https://bugs.launchpad.net/bugs/1172601.

Approved by PS Jenkins bot, MC Return.

3670. By Sam Spilsbury

Link in CMAKE_THREAD_LIBS_INIT through GTEST_BOTH_LIBRARIES so it gets
included in everything. Remove redundant links. Require FindThreads.cmake.

(LP: #1171364). Fixes: https://bugs.launchpad.net/bugs/1171364.

Approved by PS Jenkins bot, MC Return.

3669. By Sam Spilsbury

Bump VERSION to 0.9.10.0.

Approved by PS Jenkins bot, MC Return, Didier Roche.

3668. By MC Return

Shift Switcher code cleanup:

Use prefix instead of postfix increment and decrement.
Declaration and assignment of local variables in one line.
Merged if statements.
Added brackets to for loops.
Fixed indentation.
Added and removed newlines for better readability.
Added comment.

Approved by PS Jenkins bot, Sam Spilsbury.

3667. By MC Return

*Screenshot, xml:

Better plugin summary.
Added option to disable the drawing of the screenshot
selection indicator.
Added options to change color and opacity of the outline
and the inside of the rectangle indicator, default colors
have not been changed.
Other minor improvements.

*Screenshot, code:

Introduced the new variable bool selectionSizeChanged,
which is true if the size of the selection has changed.

We just want to draw the screenshot selection box, if
we are grabbed, the size has changed and the CCSM
option to draw it is enabled.
Do not render anything if indicator is disabled.

Indicator colors are now configurable.
Increased indicator box outline line width to 2.0.

Only damage the full screen once, if the grab gets
terminated, during grab just damage the region painted,
which is the screenshot selection box (LP: #1172234).

*SCreenshot, cleanup:

Minor cleanup in the rendering code.
Removed redundant #ifndef USE_GLES compiler option,
GLES can cope with enabling and disabling GL_BLEND.
Use prefix- instead of postfix increments.
Declaration and assignment of local variables in one line.
Reduced the scope of the variables x1, y1, x2 and y2.
Replaced magic number 65535.0f with const float MaxUShortFloat =
std::numeric_limits <unsigned short>::max ();.
Indentation fixes.
C++ style for comments, added comments.

(LP: #1169353, LP: #1172234). Fixes: https://bugs.launchpad.net/bugs/1169353, https://bugs.launchpad.net/bugs/1172234.

Approved by PS Jenkins bot, Sam Spilsbury.

3666. By MC Return

*Workspacenames:

New Feature:
Implemented option to adjust vertical offset for
top and bottom of screen workspacename placement.
Set the default offset to 50 pixel.

Cleanup:
Added brackets to for loop.
Use prefix increments.
Indentation fixes.
Added and removed newlines for better readability.
Added comment.
Removed TEXT_BORDER constant.
Improved tooltips.

(LP: #1172063). Fixes: https://bugs.launchpad.net/bugs/1172063.

Approved by PS Jenkins bot, Sam Spilsbury.

3665. By MC Return

*Showmouse code cleanup:

Assignment and declaration of local variables in one line.
Removed redundant brackets.
Fixed indentation.
Removed and added newlines for better readability.

*Showmouse code changes:

Removed these redundant gl calls:
glEnable (GL_TEXTURE_2D);
glDisable (GL_TEXTURE_2D);

(partially fixes LP: #1051290 and LP: #1051295).

Approved by PS Jenkins bot, Sam Spilsbury.

3664. By MC Return

*Cube Gears:

Added glDepthMask (GL_TRUE); and glDepthFunc (GL_LESS); to void
GearsScreen::cubePaintInside (...) to fix the culling on multimonitor
systems (green gear was always rendered in front).

Also fixed indentation and removed some redundant newlines.

(LP: #1168919). Fixes: https://bugs.launchpad.net/bugs/1168919.

Approved by PS Jenkins bot, Sam Spilsbury.

3663. By MC Return

*Grid code:

Simplified bool GridScreen::restoreWindow (...):
If Grid has not touched the window we return false and let core do the
dirty work.
(Thanks go to Sam Spilsbury for suggesting this solution.)

*Grid xml:

Improved the CCSM Grid put_restore_key tooltip.

(LP: #1116538). Fixes: https://bugs.launchpad.net/bugs/1116538.

Approved by PS Jenkins bot, Sam Spilsbury.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp://staging/compiz/0.9.10
This branch contains Public information 
Everyone can see this information.

Subscribers