Merge lp://staging/~marcustomlinson/unity-scopes-api/rename_child_scopes_methods into lp://staging/unity-scopes-api

Proposed by Marcus Tomlinson
Status: Merged
Approved by: Paweł Stołowski
Approved revision: 324
Merged at revision: 321
Proposed branch: lp://staging/~marcustomlinson/unity-scopes-api/rename_child_scopes_methods
Merge into: lp://staging/unity-scopes-api
Diff against target: 882 lines (+145/-132)
30 files modified
CMakeLists.txt (+1/-1)
RELEASE_NOTES.md (+5/-0)
debian/changelog (+7/-0)
debian/libunity-scopes3.symbols (+8/-8)
include/unity/scopes/AbstractScopeBase.h (+1/-1)
include/unity/scopes/Scope.h (+6/-6)
include/unity/scopes/ScopeBase.h (+14/-13)
include/unity/scopes/internal/ChildScopesRepository.h (+2/-2)
include/unity/scopes/internal/MWScope.h (+2/-2)
include/unity/scopes/internal/ScopeBaseImpl.h (+3/-3)
include/unity/scopes/internal/ScopeImpl.h (+2/-2)
include/unity/scopes/internal/ScopeObject.h (+2/-2)
include/unity/scopes/internal/ScopeObjectBase.h (+2/-2)
include/unity/scopes/internal/smartscopes/SSScopeObject.h (+2/-2)
include/unity/scopes/internal/zmq_middleware/ScopeI.h (+2/-2)
include/unity/scopes/internal/zmq_middleware/ZmqScope.h (+2/-2)
include/unity/scopes/testing/MockScope.h (+2/-2)
src/scopes/ScopeBase.cpp (+6/-6)
src/scopes/internal/ChildScopesRepository.cpp (+3/-3)
src/scopes/internal/ScopeBaseImpl.cpp (+7/-7)
src/scopes/internal/ScopeImpl.cpp (+4/-4)
src/scopes/internal/ScopeObject.cpp (+4/-4)
src/scopes/internal/smartscopes/SSScopeObject.cpp (+2/-2)
src/scopes/internal/zmq_middleware/ScopeI.cpp (+13/-13)
src/scopes/internal/zmq_middleware/ZmqScope.cpp (+11/-11)
src/scopes/internal/zmq_middleware/capnproto/Scope.capnp (+4/-4)
test/gtest/scopes/ChildScopes/ChildScopes_test.cpp (+20/-20)
test/gtest/scopes/ChildScopes/TestScope.h (+4/-4)
test/gtest/scopes/internal/RegistryObject/RegistryObject_test.cpp (+2/-2)
test/gtest/scopes/internal/zmq_middleware/ZmqMiddleware/ZmqMiddleware_test.cpp (+2/-2)
To merge this branch: bzr merge lp://staging/~marcustomlinson/unity-scopes-api/rename_child_scopes_methods
Reviewer Review Type Date Requested Status
Paweł Stołowski (community) Approve
Michi Henning (community) Approve
PS Jenkins bot (community) continuous-integration Approve
Review via email: mp+254035@code.staging.launchpad.net

Commit message

Rename "child_scopes()" to "find_child_scopes()" and "child_scopes_ordered()" to "child_scopes()" as the ordering constraint may (probably) be (re)moved.

To post a comment you must log in.
324. By Marcus Tomlinson

Insert 0replaceme for new symbols

Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :
review: Approve (continuous-integration)
Revision history for this message
Michi Henning (michihenning) wrote :

Do we want to target this to unity-scopes-api or to devel?

Also, the change is ABI-incompatible. Just saying'… ;-)

Otherwise, looks fine, seeing that it's just a straight renaming.

review: Approve
Revision history for this message
Paweł Stołowski (stolowski) wrote :

Should be targeted at devel. Otherwise looks good.

review: Needs Fixing
Revision history for this message
Paweł Stołowski (stolowski) wrote :

Confusion around landing... trunk is OK as we want that in vivid now. +1

review: Approve

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
The diff is not available at this time. You can reload the page or download it.

Subscribers

People subscribed via source and target branches

to all changes: