Merge lp://staging/~lifeless/desktop-switcher/autogen into lp://staging/desktop-switcher

Proposed by Robert Collins
Status: Rejected
Rejected by: Robert Collins
Proposed branch: lp://staging/~lifeless/desktop-switcher/autogen
Merge into: lp://staging/desktop-switcher
Diff against target: 514 lines
1 file modified
autogen.sh (+10/-499)
To merge this branch: bzr merge lp://staging/~lifeless/desktop-switcher/autogen
Reviewer Review Type Date Requested Status
Aurélien Gâteau (community) Approve
Neil J. Patel (community) Approve
Review via email: mp+14070@code.staging.launchpad.net
To post a comment you must log in.
Revision history for this message
Robert Collins (lifeless) wrote :

This should fix builds with automake1.11

Revision history for this message
Neil J. Patel (njpatel) wrote :

Although I removed this from the builds page as it's no longer in Karmic as it doesn't work very well with the latest GNOME release.

review: Approve
Revision history for this message
Robert Collins (lifeless) wrote :

On Wed, 2009-10-28 at 09:01 +0000, Neil J. Patel wrote:
> Review: Approve
> Although I removed this from the builds page as it's no longer in Karmic as it doesn't work very well with the latest GNOME release.

Ok cool - have you deleted it from bobthebuilder too?

-Rob

Revision history for this message
Neil J. Patel (njpatel) wrote :

Hmm, it wasn't autobuilt, but I guess I need to delete it from Hudson.

Revision history for this message
Aurélien Gâteau (agateau) wrote :

Can't really comment on the change, lacking some autotools fu, but I would suggest passing shell args to gnome-autogen.sh, ie invoking it as "gnome-autogen.sh "$@"'. This makes it possible to prevent gnome-autogen.sh to run ./configure or to pass additional arguments to ./configure.

review: Approve
Revision history for this message
Robert Collins (lifeless) wrote :

So, as this is approved, could someone land it? Or do I have access to do that.

@aurelien, that makes sense to me, I was just cargo culting another NBR source tree with this change though.

Revision history for this message
Robert Collins (lifeless) wrote :

obsolete thing, not needed.

Unmerged revisions

35. By Robert Collins

Use gnome autogen script.

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== modified file 'autogen.sh'
2--- autogen.sh 2008-09-24 11:03:29 +0000
3+++ autogen.sh 2009-10-28 05:35:18 +0000
4@@ -1,500 +1,11 @@
5 #!/bin/sh
6-# Run this to generate all the initial makefiles, etc.
7-
8-#name of package
9-PKG_NAME=${PKG_NAME:-Package}
10-srcdir=${srcdir:-.}
11-
12-# default version requirements ...
13-REQUIRED_AUTOCONF_VERSION=${REQUIRED_AUTOCONF_VERSION:-2.53}
14-REQUIRED_AUTOMAKE_VERSION=${REQUIRED_AUTOMAKE_VERSION:-1.9}
15-REQUIRED_LIBTOOL_VERSION=${REQUIRED_LIBTOOL_VERSION:-1.5}
16-REQUIRED_GETTEXT_VERSION=${REQUIRED_GETTEXT_VERSION:-0.12}
17-REQUIRED_GLIB_GETTEXT_VERSION=${REQUIRED_GLIB_GETTEXT_VERSION:-2.2.0}
18-REQUIRED_INTLTOOL_VERSION=${REQUIRED_INTLTOOL_VERSION:-0.30}
19-REQUIRED_PKG_CONFIG_VERSION=${REQUIRED_PKG_CONFIG_VERSION:-0.14.0}
20-REQUIRED_GTK_DOC_VERSION=${REQUIRED_GTK_DOC_VERSION:-1.0}
21-REQUIRED_DOC_COMMON_VERSION=${REQUIRED_DOC_COMMON_VERSION:-2.3.0}
22-REQUIRED_GNOME_DOC_UTILS_VERSION=${REQUIRED_GNOME_DOC_UTILS_VERSION:-0.4.2}
23-
24-# a list of required m4 macros. Package can set an initial value
25-REQUIRED_M4MACROS=${REQUIRED_M4MACROS:-}
26-FORBIDDEN_M4MACROS=${FORBIDDEN_M4MACROS:-}
27-
28-# Not all echo versions allow -n, so we check what is possible. This test is
29-# based on the one in autoconf.
30-ECHO_C=
31-ECHO_N=
32-case `echo -n x` in
33--n*)
34- case `echo 'x\c'` in
35- *c*) ;;
36- *) ECHO_C='\c';;
37- esac;;
38-*)
39- ECHO_N='-n';;
40-esac
41-
42-# some terminal codes ...
43-boldface="`tput bold 2>/dev/null`"
44-normal="`tput sgr0 2>/dev/null`"
45-printbold() {
46- echo $ECHO_N "$boldface" $ECHO_C
47- echo "$@"
48- echo $ECHO_N "$normal" $ECHO_C
49-}
50-printerr() {
51- echo "$@" >&2
52-}
53-
54-# Usage:
55-# compare_versions MIN_VERSION ACTUAL_VERSION
56-# returns true if ACTUAL_VERSION >= MIN_VERSION
57-compare_versions() {
58- ch_min_version=$1
59- ch_actual_version=$2
60- ch_status=0
61- IFS="${IFS= }"; ch_save_IFS="$IFS"; IFS="."
62- set $ch_actual_version
63- for ch_min in $ch_min_version; do
64- ch_cur=`echo $1 | sed 's/[^0-9].*$//'`; shift # remove letter suffixes
65- if [ -z "$ch_min" ]; then break; fi
66- if [ -z "$ch_cur" ]; then ch_status=1; break; fi
67- if [ $ch_cur -gt $ch_min ]; then break; fi
68- if [ $ch_cur -lt $ch_min ]; then ch_status=1; break; fi
69- done
70- IFS="$ch_save_IFS"
71- return $ch_status
72-}
73-
74-# Usage:
75-# version_check PACKAGE VARIABLE CHECKPROGS MIN_VERSION SOURCE
76-# checks to see if the package is available
77-version_check() {
78- vc_package=$1
79- vc_variable=$2
80- vc_checkprogs=$3
81- vc_min_version=$4
82- vc_source=$5
83- vc_status=1
84-
85- vc_checkprog=`eval echo "\\$$vc_variable"`
86- if [ -n "$vc_checkprog" ]; then
87- printbold "using $vc_checkprog for $vc_package"
88- return 0
89- fi
90-
91- if test "x$vc_package" = "xautomake" -a "x$vc_min_version" = "x1.4"; then
92- vc_comparator="="
93- else
94- vc_comparator=">="
95- fi
96- printbold "checking for $vc_package $vc_comparator $vc_min_version..."
97- for vc_checkprog in $vc_checkprogs; do
98- echo $ECHO_N " testing $vc_checkprog... " $ECHO_C
99- if $vc_checkprog --version < /dev/null > /dev/null 2>&1; then
100- vc_actual_version=`$vc_checkprog --version | head -n 1 | \
101- sed 's/^.*[ ]\([0-9.]*[a-z]*\).*$/\1/'`
102- if compare_versions $vc_min_version $vc_actual_version; then
103- echo "found $vc_actual_version"
104- # set variables
105- eval "$vc_variable=$vc_checkprog; \
106- ${vc_variable}_VERSION=$vc_actual_version"
107- vc_status=0
108- break
109- else
110- echo "too old (found version $vc_actual_version)"
111- fi
112- else
113- echo "not found."
114- fi
115- done
116- if [ "$vc_status" != 0 ]; then
117- printerr "***Error***: You must have $vc_package $vc_comparator $vc_min_version installed"
118- printerr " to build $PKG_NAME. Download the appropriate package for"
119- printerr " from your distribution or get the source tarball at"
120- printerr " $vc_source"
121- printerr
122- fi
123- return $vc_status
124-}
125-
126-# Usage:
127-# require_m4macro filename.m4
128-# adds filename.m4 to the list of required macros
129-require_m4macro() {
130- case "$REQUIRED_M4MACROS" in
131- $1\ * | *\ $1\ * | *\ $1) ;;
132- *) REQUIRED_M4MACROS="$REQUIRED_M4MACROS $1" ;;
133- esac
134-}
135-
136-forbid_m4macro() {
137- case "$FORBIDDEN_M4MACROS" in
138- $1\ * | *\ $1\ * | *\ $1) ;;
139- *) FORBIDDEN_M4MACROS="$FORBIDDEN_M4MACROS $1" ;;
140- esac
141-}
142-
143-# Usage:
144-# add_to_cm_macrodirs dirname
145-# Adds the dir to $cm_macrodirs, if it's not there yet.
146-add_to_cm_macrodirs() {
147- case $cm_macrodirs in
148- "$1 "* | *" $1 "* | *" $1") ;;
149- *) cm_macrodirs="$cm_macrodirs $1";;
150- esac
151-}
152-
153-# Usage:
154-# print_m4macros_error
155-# Prints an error message saying that autoconf macros were misused
156-print_m4macros_error() {
157- printerr "***Error***: some autoconf macros required to build $PKG_NAME"
158- printerr " were not found in your aclocal path, or some forbidden"
159- printerr " macros were found. Perhaps you need to adjust your"
160- printerr " ACLOCAL_FLAGS?"
161- printerr
162-}
163-
164-# Usage:
165-# check_m4macros
166-# Checks that all the requested macro files are in the aclocal macro path
167-# Uses REQUIRED_M4MACROS and ACLOCAL variables.
168-check_m4macros() {
169- # construct list of macro directories
170- cm_macrodirs=`$ACLOCAL --print-ac-dir`
171- # aclocal also searches a version specific dir, eg. /usr/share/aclocal-1.9
172- # but it contains only Automake's own macros, so we can ignore it.
173-
174- # Read the dirlist file, supported by Automake >= 1.7.
175- if compare_versions 1.7 $AUTOMAKE_VERSION && [ -s $cm_macrodirs/dirlist ]; then
176- cm_dirlist=`sed 's/[ ]*#.*//;/^$/d' $cm_macrodirs/dirlist`
177- if [ -n "$cm_dirlist" ] ; then
178- for cm_dir in $cm_dirlist; do
179- if [ -d $cm_dir ]; then
180- add_to_cm_macrodirs $cm_dir
181- fi
182- done
183- fi
184- fi
185-
186- # Parse $ACLOCAL_FLAGS
187- set - $ACLOCAL_FLAGS
188- while [ $# -gt 0 ]; do
189- if [ "$1" = "-I" ]; then
190- add_to_cm_macrodirs "$2"
191- shift
192- fi
193- shift
194- done
195-
196- cm_status=0
197- if [ -n "$REQUIRED_M4MACROS" ]; then
198- printbold "Checking for required M4 macros..."
199- # check that each macro file is in one of the macro dirs
200- for cm_macro in $REQUIRED_M4MACROS; do
201- cm_macrofound=false
202- for cm_dir in $cm_macrodirs; do
203- if [ -f "$cm_dir/$cm_macro" ]; then
204- cm_macrofound=true
205- break
206- fi
207- # The macro dir in Cygwin environments may contain a file
208- # called dirlist containing other directories to look in.
209- if [ -f "$cm_dir/dirlist" ]; then
210- for cm_otherdir in `cat $cm_dir/dirlist`; do
211- if [ -f "$cm_otherdir/$cm_macro" ]; then
212- cm_macrofound=true
213- break
214- fi
215- done
216- fi
217- done
218- if $cm_macrofound; then
219- :
220- else
221- printerr " $cm_macro not found"
222- cm_status=1
223- fi
224- done
225- fi
226- if [ "$cm_status" != 0 ]; then
227- print_m4macros_error
228- return $cm_status
229- fi
230- if [ -n "$FORBIDDEN_M4MACROS" ]; then
231- printbold "Checking for forbidden M4 macros..."
232- # check that each macro file is in one of the macro dirs
233- for cm_macro in $FORBIDDEN_M4MACROS; do
234- cm_macrofound=false
235- for cm_dir in $cm_macrodirs; do
236- if [ -f "$cm_dir/$cm_macro" ]; then
237- cm_macrofound=true
238- break
239- fi
240- done
241- if $cm_macrofound; then
242- printerr " $cm_macro found (should be cleared from macros dir)"
243- cm_status=1
244- fi
245- done
246- fi
247- if [ "$cm_status" != 0 ]; then
248- print_m4macros_error
249- fi
250- return $cm_status
251-}
252-
253-# try to catch the case where the macros2/ directory hasn't been cleared out.
254-forbid_m4macro gnome-cxx-check.m4
255-
256-want_libtool=false
257-want_gettext=false
258-want_glib_gettext=false
259-want_intltool=false
260-want_pkg_config=false
261-want_gtk_doc=false
262-want_gnome_doc_utils=false
263-
264-configure_files="`find $srcdir -name '{arch}' -prune -o -name '_darcs' -prune -o -name '.??*' -prune -o -name configure.ac -print -o -name configure.in -print`"
265-for configure_ac in $configure_files; do
266- dirname=`dirname $configure_ac`
267- if [ -f $dirname/NO-AUTO-GEN ]; then
268- echo skipping $dirname -- flagged as no auto-gen
269- continue
270- fi
271- if grep "^A[CM]_PROG_LIBTOOL" $configure_ac >/dev/null ||
272- grep "^LT_INIT" $configure_ac >/dev/null; then
273- want_libtool=true
274- fi
275- if grep "^AM_GNU_GETTEXT" $configure_ac >/dev/null; then
276- want_gettext=true
277- fi
278- if grep "^AM_GLIB_GNU_GETTEXT" $configure_ac >/dev/null; then
279- want_glib_gettext=true
280- fi
281- if grep "^AC_PROG_INTLTOOL" $configure_ac >/dev/null ||
282- grep "^IT_PROG_INTLTOOL" $configure_ac >/dev/null; then
283- want_intltool=true
284- fi
285- if grep "^PKG_CHECK_MODULES" $configure_ac >/dev/null; then
286- want_pkg_config=true
287- fi
288- if grep "^GTK_DOC_CHECK" $configure_ac >/dev/null; then
289- want_gtk_doc=true
290- fi
291- if grep "^GNOME_DOC_INIT" $configure_ac >/dev/null; then
292- want_gnome_doc_utils=true
293- fi
294-
295- # check to make sure gnome-common macros can be found ...
296- if grep "^GNOME_COMMON_INIT" $configure_ac >/dev/null ||
297- grep "^GNOME_DEBUG_CHECK" $configure_ac >/dev/null ||
298- grep "^GNOME_MAINTAINER_MODE_DEFINES" $configure_ac >/dev/null; then
299- require_m4macro gnome-common.m4
300- fi
301- if grep "^GNOME_COMPILE_WARNINGS" $configure_ac >/dev/null ||
302- grep "^GNOME_CXX_WARNINGS" $configure_ac >/dev/null; then
303- require_m4macro gnome-compiler-flags.m4
304- fi
305-done
306-
307-DIE=0
308-
309-#tell Mandrake autoconf wrapper we want autoconf 2.5x, not 2.13
310-WANT_AUTOCONF_2_5=1
311-export WANT_AUTOCONF_2_5
312-version_check autoconf AUTOCONF 'autoconf2.50 autoconf autoconf-2.53' $REQUIRED_AUTOCONF_VERSION \
313- "http://ftp.gnu.org/pub/gnu/autoconf/autoconf-$REQUIRED_AUTOCONF_VERSION.tar.gz" || DIE=1
314-AUTOHEADER=`echo $AUTOCONF | sed s/autoconf/autoheader/`
315-
316-case $REQUIRED_AUTOMAKE_VERSION in
317- 1.4*) automake_progs="automake-1.4" ;;
318- 1.5*) automake_progs="automake-1.10 automake-1.9 automake-1.8 automake-1.7 automake-1.6 automake-1.5" ;;
319- 1.6*) automake_progs="automake-1.10 automake-1.9 automake-1.8 automake-1.7 automake-1.6" ;;
320- 1.7*) automake_progs="automake-1.10 automake-1.9 automake-1.8 automake-1.7" ;;
321- 1.8*) automake_progs="automake-1.10 automake-1.9 automake-1.8" ;;
322- 1.9*) automake_progs="automake-1.10 automake-1.9" ;;
323- 1.10*) automake_progs="automake-1.10" ;;
324-esac
325-version_check automake AUTOMAKE "$automake_progs" $REQUIRED_AUTOMAKE_VERSION \
326- "http://ftp.gnu.org/pub/gnu/automake/automake-$REQUIRED_AUTOMAKE_VERSION.tar.gz" || DIE=1
327-ACLOCAL=`echo $AUTOMAKE | sed s/automake/aclocal/`
328-
329-if $want_libtool; then
330- version_check libtool LIBTOOLIZE libtoolize $REQUIRED_LIBTOOL_VERSION \
331- "http://ftp.gnu.org/pub/gnu/libtool/libtool-$REQUIRED_LIBTOOL_VERSION.tar.gz" || DIE=1
332- require_m4macro libtool.m4
333-fi
334-
335-if $want_gettext; then
336- version_check gettext GETTEXTIZE gettextize $REQUIRED_GETTEXT_VERSION \
337- "http://ftp.gnu.org/pub/gnu/gettext/gettext-$REQUIRED_GETTEXT_VERSION.tar.gz" || DIE=1
338- require_m4macro gettext.m4
339-fi
340-
341-if $want_glib_gettext; then
342- version_check glib-gettext GLIB_GETTEXTIZE glib-gettextize $REQUIRED_GLIB_GETTEXT_VERSION \
343- "ftp://ftp.gtk.org/pub/gtk/v2.2/glib-$REQUIRED_GLIB_GETTEXT_VERSION.tar.gz" || DIE=1
344- require_m4macro glib-gettext.m4
345-fi
346-
347-if $want_intltool; then
348- version_check intltool INTLTOOLIZE intltoolize $REQUIRED_INTLTOOL_VERSION \
349- "http://ftp.gnome.org/pub/GNOME/sources/intltool/" || DIE=1
350- require_m4macro intltool.m4
351-fi
352-
353-if $want_pkg_config; then
354- version_check pkg-config PKG_CONFIG pkg-config $REQUIRED_PKG_CONFIG_VERSION \
355- "'http://www.freedesktop.org/software/pkgconfig/releases/pkgconfig-$REQUIRED_PKG_CONFIG_VERSION.tar.gz" || DIE=1
356- require_m4macro pkg.m4
357-fi
358-
359-if $want_gtk_doc; then
360- version_check gtk-doc GTKDOCIZE gtkdocize $REQUIRED_GTK_DOC_VERSION \
361- "http://ftp.gnome.org/pub/GNOME/sources/gtk-doc/" || DIE=1
362- require_m4macro gtk-doc.m4
363-fi
364-
365-if $want_gnome_doc_utils; then
366- version_check gnome-doc-utils GNOME_DOC_PREPARE gnome-doc-prepare $REQUIRED_GNOME_DOC_UTILS_VERSION \
367- "http://ftp.gnome.org/pub/GNOME/sources/gnome-doc-utils/" || DIE=1
368-fi
369-
370-if [ "x$USE_COMMON_DOC_BUILD" = "xyes" ]; then
371- version_check gnome-common DOC_COMMON gnome-doc-common \
372- $REQUIRED_DOC_COMMON_VERSION " " || DIE=1
373-fi
374-
375-check_m4macros || DIE=1
376-
377-if [ "$DIE" -eq 1 ]; then
378- exit 1
379-fi
380-
381-if [ "$#" = 0 -a "x$NOCONFIGURE" = "x" ]; then
382- printerr "**Warning**: I am going to run \`configure' with no arguments."
383- printerr "If you wish to pass any to it, please specify them on the"
384- printerr \`$0\'" command line."
385- printerr
386-fi
387-
388-topdir=`pwd`
389-for configure_ac in $configure_files; do
390- dirname=`dirname $configure_ac`
391- basename=`basename $configure_ac`
392- if [ -f $dirname/NO-AUTO-GEN ]; then
393- echo skipping $dirname -- flagged as no auto-gen
394- elif [ ! -w $dirname ]; then
395- echo skipping $dirname -- directory is read only
396- else
397- printbold "Processing $configure_ac"
398- cd $dirname
399-
400- # Note that the order these tools are called should match what
401- # autoconf's "autoupdate" package does. See bug 138584 for
402- # details.
403-
404- # programs that might install new macros get run before aclocal
405- if grep "^A[CM]_PROG_LIBTOOL" $basename >/dev/null ||
406- grep "^LT_INIT" $basename >/dev/null; then
407- printbold "Running $LIBTOOLIZE..."
408- $LIBTOOLIZE --force --copy || exit 1
409- fi
410-
411- if grep "^AM_GLIB_GNU_GETTEXT" $basename >/dev/null; then
412- printbold "Running $GLIB_GETTEXTIZE... Ignore non-fatal messages."
413- echo "no" | $GLIB_GETTEXTIZE --force --copy || exit 1
414- elif grep "^AM_GNU_GETTEXT" $basename >/dev/null; then
415- if grep "^AM_GNU_GETTEXT_VERSION" $basename > /dev/null; then
416- printbold "Running autopoint..."
417- autopoint --force || exit 1
418- else
419- printbold "Running $GETTEXTIZE... Ignore non-fatal messages."
420- echo "no" | $GETTEXTIZE --force --copy || exit 1
421- fi
422- fi
423-
424- if grep "^AC_PROG_INTLTOOL" $basename >/dev/null ||
425- grep "^IT_PROG_INTLTOOL" $basename >/dev/null; then
426- printbold "Running $INTLTOOLIZE..."
427- $INTLTOOLIZE --force --copy --automake || exit 1
428- fi
429- if grep "^GTK_DOC_CHECK" $basename >/dev/null; then
430- printbold "Running $GTKDOCIZE..."
431- $GTKDOCIZE --copy || exit 1
432- fi
433-
434- if [ "x$USE_COMMON_DOC_BUILD" = "xyes" ]; then
435- printbold "Running gnome-doc-common..."
436- gnome-doc-common --copy || exit 1
437- fi
438- if grep "^GNOME_DOC_INIT" $basename >/dev/null; then
439- printbold "Running $GNOME_DOC_PREPARE..."
440- $GNOME_DOC_PREPARE --force --copy || exit 1
441- fi
442-
443- # Now run aclocal to pull in any additional macros needed
444-
445- # if the AC_CONFIG_MACRO_DIR() macro is used, pass that
446- # directory to aclocal.
447- m4dir=`cat "$basename" | grep '^AC_CONFIG_MACRO_DIR' | sed -n -e 's/AC_CONFIG_MACRO_DIR(\([^()]*\))/\1/p' | sed -e 's/^\[\(.*\)\]$/\1/' | sed -e 1q`
448- if [ -n "$m4dir" ]; then
449- m4dir="-I $m4dir"
450- fi
451- printbold "Running $ACLOCAL..."
452- $ACLOCAL $m4dir $ACLOCAL_FLAGS || exit 1
453-
454- if grep "GNOME_AUTOGEN_OBSOLETE" aclocal.m4 >/dev/null; then
455- printerr "*** obsolete gnome macros were used in $configure_ac"
456- fi
457-
458- # Now that all the macros are sorted, run autoconf and autoheader ...
459- printbold "Running $AUTOCONF..."
460- $AUTOCONF || exit 1
461- if grep "^A[CM]_CONFIG_HEADER" $basename >/dev/null; then
462- printbold "Running $AUTOHEADER..."
463- $AUTOHEADER || exit 1
464- # this prevents automake from thinking config.h.in is out of
465- # date, since autoheader doesn't touch the file if it doesn't
466- # change.
467- test -f config.h.in && touch config.h.in
468- fi
469-
470- # Finally, run automake to create the makefiles ...
471- printbold "Running $AUTOMAKE..."
472- if [ -f COPYING ]; then
473- cp -pf COPYING COPYING.autogen_bak
474- fi
475- if [ -f INSTALL ]; then
476- cp -pf INSTALL INSTALL.autogen_bak
477- fi
478- if [ $REQUIRED_AUTOMAKE_VERSION != 1.4 ]; then
479- $AUTOMAKE --gnu --add-missing --force --copy || exit 1
480- else
481- $AUTOMAKE --gnu --add-missing --copy || exit 1
482- fi
483- if [ -f COPYING.autogen_bak ]; then
484- cmp COPYING COPYING.autogen_bak > /dev/null || cp -pf COPYING.autogen_bak COPYING
485- rm -f COPYING.autogen_bak
486- fi
487- if [ -f INSTALL.autogen_bak ]; then
488- cmp INSTALL INSTALL.autogen_bak > /dev/null || cp -pf INSTALL.autogen_bak INSTALL
489- rm -f INSTALL.autogen_bak
490- fi
491-
492- cd "$topdir"
493- fi
494-done
495-
496-conf_flags="--enable-maintainer-mode"
497-
498-if test x$NOCONFIGURE = x; then
499- printbold Running $srcdir/configure $conf_flags "$@" ...
500- $srcdir/configure $conf_flags "$@" \
501- && echo Now type \`make\' to compile $PKG_NAME || exit 1
502-else
503- echo Skipping configure process.
504-fi
505+
506+PKG_NAME="desktop-switcher"
507+
508+which gnome-autogen.sh || {
509+ echo "You need gnome-common from GNOME SVN"
510+ exit 1
511+}
512+
513+USE_GNOME2_MACROS=1 \
514+. gnome-autogen.sh

Subscribers

People subscribed via source and target branches

to all changes: