lp://staging/~laney/ubuntu/quantal/avahi/merge-0.6.31-1

Created by Iain Lane and last modified
Get this branch:
bzr branch lp://staging/~laney/ubuntu/quantal/avahi/merge-0.6.31-1
Only Iain Lane can upload to this branch. If you are Iain Lane please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Iain Lane
Status:
Development

Recent revisions

43. By Iain Lane

Drop change:

Pass CFLAGS from the environment through to configure. Seems to be no
longer necessary with the move to compat 9.

42. By Iain Lane

Drop change "Build with CFLAGS=-UGTK_DISABLE_DEPRECATED due to deprecation of gtk_vbox_new." No longer necessary.

41. By Iain Lane

Merge with Debian unstable

* Merge with Debian unstable. Remaining changes:
  - Build with CFLAGS=-UGTK_DISABLE_DEPRECATED due to deprecation of
    gtk_vbox_new.
  - debian/control: Add versioned dependency on the dbus that satisfies our
    upstart job dependency.
  - Add udebs corresponding to libavahi-common3 and libavahi-core7, so
    that we can use them for Eucalyptus integration in the installer.
  - Add debian/avahi-daemon.upstart, debian/avahi-dnsconfd.upstart
  - debian/avahi-{daemon,dnsconfd}.links: Remove systemd configuration
    symlinks.
  - Pass CFLAGS from the environment through to configure. This by default
    will turn on optimisations and debug symbol generation, both of which
    are currently disabled.
* Dropped changes
  - debian/avahi-autoipd.{pre,post}inst: Adjust package versions for conffile
    migration for the version when Ubuntu did the DHCP4 migration. We're now
    one LTS cycle since this, so there's no need to keep code paths for this
    upgrade.
* New upstream release.
* Mark private stdb_* symbols in libavahi-ui and libavahi-ui-gtk3 as
  optional.
* Bump Build-Depends on debhelper to (>= 9).
* Bump Standards-Version to 3.9.3. No further changes.
* Use new dh_installdeb maintscript facility to (re)move the old conffiles
  for avahi-autoipd and avahi-dnsconfd.
* Switch to dh_python2. (Closes: #637552)
* Simplify postinst for avahi-autoipd and avahi-daemon.
* Rebuild to enable hardened build flags. (Closes: #655188)
* Use term GLib consistently in the package description. (Closes: #633783)

40. By Iain Lane

Build using dh_python2.

39. By Chris Halse Rogers

Merge from Debian testing

38. By Chris Halse Rogers

Pass CFLAGS through to configure to enable optimisations & debug symbol generation

37. By Sebastien Bacher

releasing version 0.6.30-4ubuntu1

36. By Steve Langasek

releasing version 0.6.30-3ubuntu3

35. By Steve Langasek

Build with CFLAGS=-UGTK_DISABLE_DEPRECATED due to deprecation of
gtk_vbox_new.

34. By Steve Langasek

No-change rebuild to get consistent changelog files for multiarch.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp://staging/ubuntu/quantal/avahi
This branch contains Public information 
Everyone can see this information.

Subscribers