Merge ppa-dev-tools:fix-lp-credentials into ppa-dev-tools:main
Status: | Merged |
---|---|
Merge reported by: | Bryce Harrington |
Merged at revision: | 9eb18737f3409a533ae7f677fa9bfc10baf7000a |
Proposed branch: | ppa-dev-tools:fix-lp-credentials |
Merge into: | ppa-dev-tools:main |
Diff against target: |
431 lines (+141/-76) 6 files modified
INSTALL.md (+0/-1) ppa/lp.py (+1/-7) ppa/ppa.py (+119/-50) ppa/ppa_group.py (+1/-1) scripts/ppa (+18/-3) tests/test_lp.py (+2/-14) |
Related bugs: |
Reviewer | Review Type | Date Requested | Status |
---|---|---|---|
Christian Ehrhardt (community) | Approve | ||
Canonical Server Reporter | Pending | ||
Review via email: mp+429807@code.staging.launchpad.net |
Description of the change
This branch focuses mainly on bug fixes, and improvements to error handling and return values generally.
I wanted to also flesh out the test cases for ppa.py since currently they're pretty minimal, and ppa.py still has some pylint problems and some unimplemented internal functionality. But this is a good step forward.
The "Improve error handling and return behavior" commit is a bit of a mishmash of several changes that more properly should have been done as several separate commits. I'll beg forgiveness for my laziness here, but hopefully it's straightforward enough to review.
While this tackles many of the bugs Christian filed from his testing, I've not tackled them all, and there are almost certainly more corner cases I've not addressed. Please mention any you can think of or spot.
There was an error fetching revisions from git servers. Please try again in a few minutes. If the problem persists, contact Launchpad support.
Nothing severe, you can address this in a later PR, but IMHO "ppa", "Ppa", "PPA" is rather inconsistent.
"""Provides a Ppa for the named ppa.
This example:
def get(self, ppa_name):
:rtype: ppa.Ppa
:returns: A Ppa object describing the named ppa
"A Ppa" it isn't at the beginning of the sentence, so why start upper case?
And if it would generally be "Ppa" then why is the one at the end all lower case.
rtype: ppa.Ppa seems odd too, isn't that "ppa.ppa"? In other places it is all lower already like "self.ppa_name".
My suggestion would be to make:
- all variable (unless there is another rule) fully lower (local) upper (global if any) case.
- All text mentions of PPA all uppercase everywhere, that is how people write about it usually
WDYT?